Honda Odyssey Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2009 Odyssey 3.5 Touring.
Upon engine startup I get a flashing engine light.
The code is P0305 - Misfire Cyl 5.

I changed the Coil, Plug, and Injector. New coil and plug have spark.
Still misfiring.
It detects it immediately after I clear codes and then regulates RPM to max 3500.

Any help would be greatly appreciated.
 

·
Registered
2006 Honda Odyssey (EX)
Joined
·
4,870 Posts
Stop simply throwing parts at it. Your original coil is probably just fine and better than any aftermarket junk coil you may put on it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Stop simply throwing parts at it. Your original coil is probably just fine and better than any aftermarket junk coil you may put on it.
Thanks for replying.
The plugs needed replacing anyway. I was able to compare the spark of the old coil with the new one. Either way, those parts are fine. On all the other sites I read it said possible injector. Any other advice? Thanks in advance!
 

·
Registered
Joined
·
2,682 Posts
So after starting it misfires? The engine is idling rough? It's not unusual that the cylinder reported in the code is not the one that's misfiring.
Do a coil drop test. With a rough idle, unplug one coilpack at a time. If the idle is rougher, reconnect and test the next cylinder. When the idle does not change- you found the cylinder that's misfiring.
 
  • Like
Reactions: Odyssey.owner

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
So after starting it misfires? The engine is idling rough? It's not unusual that the cylinder reported in the code is not the one that's misfiring.
Do a coil drop test. With a rough idle, unplug one coilpack at a time. If the idle is rougher, reconnect and test the next cylinder. When the idle does not change- you found the cylinder that's misfiring.
Oh intetesting. Ill trt on all of them. I did that on cyl 5. It's definitely 5. However when I do a spark test with the coil and plug outside of the cyl, it fires. Makes no sense.
 

·
Registered
Joined
·
2,682 Posts
It's easier to just unplug the connector to the coil. I do my test by unscrewing the coil and pulling it off the plug. Then I slowly reconnect and can actually hear the spark as it nears the plug to confirm that it's firing.
My first misfire on my '99 was only one failed coil. On my '02 had to replace 2 coils. (I'm cheap, got my replacement Hitachi coils from the u-pick yard!)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
It's easier to just unplug the connector to the coil. I do my test by unscrewing the coil and pulling it off the plug. Then I slowly reconnect and can actually hear the spark as it nears the plug to confirm that it's firing.
My first misfire on my '99 was only one failed coil. On my '02 had to replace 2 coils. (I'm cheap, got my replacement Hitachi coils from the u-pick yard!)
I did that on the front bank but not on the rear bank. I'll seen if any of the rear ones make it stumble more. Thanks!
 

·
Registered
Joined
·
4,761 Posts
Welcome to this forum.
You should consider muzzling your VCM.
VCM can cause misfires on certain cylinders.
 
  • Like
Reactions: Bjm0517

·
Registered
Joined
·
4,761 Posts

·
Registered
2010 EX-L 245,000 2010 Touring 110,000
Joined
·
264 Posts

·
Registered
Joined
·
4,761 Posts
I just got the SVCM and my odyssey is still misfiring and idling rough.
Give your SVCM some time. It may take a few months. Also, in your other post you said you have not yet replaced your spark plugs. You need to do that.
 
  • Like
Reactions: Boberino

·
Registered
2006 Honda Odyssey (EX)
Joined
·
4,870 Posts
So @dvpatel, a little funny that this happens after our little discussion the other day. You were right, and I didn't remember hearing of any torn intake boots on VCM-2 3rd gens either. And somewhat conveniently we have one here...
 
  • Like
Reactions: dvpatel

·
Administrator
Joined
·
14,960 Posts
So @dvpatel, a little funny that this happens after our little discussion the other day. You were right, and I didn't remember hearing of any torn intake boots on VCM-2 3rd gens either. And somewhat conveniently we have one here...
True. I think this one may be a fluke unless masses of the members start posting their intake tube cracked posts. :)
 
  • Like
Reactions: WiiMaster

·
Registered
2006 Honda Odyssey (EX)
Joined
·
4,870 Posts
True. I think this one may be a fluke unless masses of the members start posting their intake tube cracked posts. :)
Adding further to the humor, my mechanic discovered today that I also have a cracked intake hose :ROFLMAO:. Must not be too serious yet, because had he not noticed and showed me, I would have had no idea, I had zero symptoms like stalling or misfires.

But in this case it makes sense because I also have two bad motor mounts that likely contributed
 

·
Administrator
Joined
·
14,960 Posts
Adding further to the humor, my mechanic discovered today that I also have a cracked intake hose :ROFLMAO:. Must not be too serious yet, because had he not noticed and showed me, I would have had no idea, I had zero symptoms like stalling or misfires.

But in this case it makes sense because I also have two bad motor mounts that likely contributed
Is your Ody Muzzled? :p
 

·
Registered
2006 Honda Odyssey (EX)
Joined
·
4,870 Posts
  • Haha
Reactions: kernel
1 - 20 of 20 Posts
Top