Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi there,

I am new to this whole thing but am so desperate to find a solution for my Odyssey. It started rough idling a few weeks ago. A mechanic said it was the idle sensor, cleaned it and it was good for 3 days. Then it started again. It idles roughest when in drive, not so bad in park or neutral. Drives absolutely fine. Starts fine first thing in the morning or first start of the day but struggles as the day progresses. I'm a mum so spend lots of time in and out of the car. Car is now on 138 000km's.
Took the car to a mechanic who himself has an odyssey. He cleaned out the throttle body valve and it was great. However, after a day my engine light came on but only for a few km's then went off, nothing the rest of that day. No engine light or rough idle. Next day the engine light did the same but went off after a few km's and idle was still good. Then day 3 the rough idle was back but no engine light.
Took it back to the mechanic who had it for 2 weeks and he eventually gave up - said he tried everything he could think of but I'm not convinced.

Does anyone have any suggestions?

Please help

Thanks
 

·
Registered
Joined
·
768 Posts
If you are in Africa, then I think you have the ody sold in the rest of the world, rather than the US specific version.
Maybe not, tell us more about your ody, post a pic is it diesel?
 

·
Registered
Joined
·
318 Posts
It started rough idling a few weeks ago.
Did your Ody version come with an EGR (Exhaust Gas Recirculation) valve?

If so, perhaps remove and clean/replace the valve as well as clean the adjacent intake manifold.
If not, scroll down and check the related threads below for other ideas...

Welcome to Odyclub, and hope you resolve the problem!
 
1 - 4 of 4 Posts
Top