Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Just bought an 03 Odyssey. Previous owner said problem in the winter
and pax sliding door stopped working. It won't open by hand or by power.
New to this forum please advise. Have search and tried a few things
but no luck. right now back panel is off. Tried pulling fuses.
It just seems like it is locked whether locked or unlocked. When
I press close I can see the motor kind of move just abit and stops.
Any advise would be greatly appreciated.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
I thought it might be the actuator, but I broke down and took it
to the dealer and they said my pax sliding door middle roller
assembly needs to be replaced as it is jammed. I'm hoping this
is something I can do. Any direction for instructions on how
to do this? I'll start searching the threads. I guess I will have
to get the door off to get at every thing. Any tips would be
appreciated. I know where the screws are under the tail light
but how do I get the middle strip off after I take out the four
screw on the end? thanks
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Lots of reading and loving this site more and more. Got the small
panel off and sprayed wd40 on the roller assembly and with a little
elbow grease voila the door finally opened. I see I need new rollers.
Propped up the door and now looking at taking the roller assembly off.
Maybe fixing it for the 5 dollar fix if I can find the right nylon bushing
here in Canada. If anyone knows where please advise.
thanks
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Trip to Home Hardware and came away with a pvc plumbing piece that
looks about the right size and cut it to size and used a dremel tool
and bought e clips at carquest and for under 3 bucks roller is fixed.
Dealer wanted 420 bucks. Great news the door will close with power
but not open with power. Manually works both ways but is hard
going. When the door closes using power I get door light on.
It doesn't seem to be closing solid all the way. Any advice?
 
1 - 5 of 5 Posts
Top