Honda Odyssey Forum banner
1 - 6 of 6 Posts

·
Registered
2004 Honda Odyssey
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys. Have a 2004 Odyssey which the radio and screen for navigation/camera etc has stopped working.
radio came on the other day and died again. Seems like it comes on once a month then nothing. Screen has been blank for months, no sign of life what so ever.
so far I have checked all fuses and there fine. Checked back of screen unit which is an pioneer TVM-6037 zh and all connections and wiring seem fine. Removed battery to charge and still nothing. It’s has a HDD in there and can hear it spinning. CD player has never worked but not sure if it’s a region thing or fault. Also could be cold solder connections in the screen itself but why would that effect radio powering on.
if some one has had a similar problem as I’ve heard it’s common in this model could you please let me know.
will try and upload pic of system.
kind regards
Brian.
Land vehicle Vehicle Car Honda Honda odyssey
 

·
Registered
Joined
·
3 Posts
Hi there, did you ever find the reason for this as I am having the same issue and have exactly the same model as you. Thanks.
 

·
Registered
Joined
·
3 Posts
Also can you please tell me the model of your car? I brought mine last week and can't seem to find out exactly what model it is? All I know is its a 2004 facelift model. Can you please help? Thanks
 

·
Registered
Joined
·
1,937 Posts
From the picture, it's right hand drive so this is an International Odyssey with conventional doors, which is probably what you have down under. Possibly the 4 cylinder RB2? Maybe check out Honda Odyssey (international) - Wikipedia for more info. This section is for the North American 6 cylinder RL1 with sliding doors. Our radio/nav is totally different.
 
  • Like
Reactions: Arie12

·
Registered
Joined
·
3 Posts
From the picture, it's right hand drive so this is an International Odyssey with conventional doors, which is probably what you have down under. Possibly the 4 cylinder RB2? Maybe check out Honda Odyssey (international) - Wikipedia for more info. This section is for the North American 6 cylinder RL1 with sliding doors. Our radio/nav is totally different.
Thanks for that info. Mine is a right hand drive also, hence my comment. My dash layout is identical to this one. 😊
I still haven't sorted the issue, don't know where to start but it's strange because sometimes I turn the key and everything works perfectly, reverse camera etc and other times nothing, no radio, nav is blank? Why would everything work perfectly sometimes?
 

·
Registered
Joined
·
1,937 Posts
Loose connection or oxidized connection? :unsure: Could try opening the dash and accessing the radio- unplugging and replugging the connectors might fix this sporadic issue. (Or it could open a bigger can of worms!)
 
  • Like
Reactions: Arie12
1 - 6 of 6 Posts
Top