Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have recently bought a 2003 EX and am having issues with misfires and occasional hard starts. The timing belt , plugs, and one coil pack have been replaced, but the symptoms remain. My local mechanic has given up and told me to live with it or take it to the dealer. The engine codes are for misfires on cylinders 1 - 6 and then a code for random misfires. The puzzling part is the random hard starts. It seems to happen more when warm, but the engine has to crank a lot and then barely sputters to life. I am wondering if the EGR valve could be occasionally getting stuck open causing the air/fuel mixture to be off causing the hard starts ? There have not been any codes about the EGR valve.
As a test, I was thinking about unplugging the electrical connector from the EGR for a day to so if the starting issue goes away ?
Thoughts ?

Thank you.
 

·
Registered
Joined
·
6 Posts
Your mechanic said "live with it"? Find a new mechanic.

I also have a 2003 (nearing 100K miles) and experienced similar problems with multiple misfires on all 6 cylinders. I replaced the EGR valve (an easy repair for $75 in parts). Still ran rough, but the only code remaining was cylinder #2 misfire. Turned out that coil was bad.

So I would suggest replacing the EGR valve, then make sure all 6 coils are really working properly.
 

·
Registered
Joined
·
3,163 Posts
Read through the many misfire threads. There is a lot of information on how to diagnose the problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
The local parts shop wants $225 for an EGR valve so I was hoping to be able to determine if that could be the issue before spending the money. I've been doing a lot of research on here and there are a lot of different fixes like valve job, fuel injectors, etc., but it is the random hard to start problem that makes me think it might be the EGR valve sticking open. I would think anything else would cause a hard start all the time.
 

·
Registered
Joined
·
21 Posts
Dwiggins,

I have a similar occasional hard start issue on a 2000 LX with 174,000 miles, but do not have misfires. About 10-20% of the time, it has crank times of 2-5 seconds instead of 1sec or less and then barely kicks over and starts. The MIL light works, but does not come on and stay on, and no service codes are stored.

Have you solved your hard start issue? I'm suspecting a fuel pressure leak-down after key-off issue. I believe the fuel rail is supposed to stay pressurized after turning the engine off. If there is a check valve that is leaking fuel back to the tank, more than a second or two of crank time might be needed to re-pressurize.

regards
 
1 - 7 of 7 Posts
Top