Honda Odyssey Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I have been researching this problem on this forum for a few days now, but PLEASE someone enlighten me if this is an obvious/previously discussed issue.

Recently bought a 2009 Odyssey EX-L with 132k from my brother in law. He said about 2.5 years ago the air in the back stopped blowing (he said he couldn't remember any other symptoms, ie whether it went out suddenly or not). That is still the case today. Front AC and heat work great but nothing in the rear. When I push the "rear" button on the climate control settings, the green light does not light up and the rear control module does not turn on as well. The other functions and lights works on the rest of the front control module.

Fuses look good. I tried hitting the back panel by the rear blower motor= no go. At this point of my research, it seems like it could be the relay, but then I thought that no air would come on at all. Maybe it's the rear resistor? But it seems like that only helps if it's blowing hot and it should cold.

Any help would be appreciated!
 

·
Registered
Joined
·
1,547 Posts
Wait a sec! TurboVan is asking the original poster- TurboVan if you figured it out. :unsure: If you're asking, I'm guessing you didn't figure it out! :ROFLMAO:
 

·
Super Moderator
Joined
·
13,875 Posts
Wait a sec! TurboVan is asking the original poster- TurboVan if you figured it out. :unsure: If you're asking, I'm guessing you didn't figure it out! :ROFLMAO:
😂

Needed that laugh this morning.
 

·
Super Moderator
Joined
·
13,875 Posts
If all the fuses check out, I believe the control panel may have a dry solder or something might have burned out on it. The front panel controls if the rear controls work or not and that may be why the rear controls don't work.

There is a Rear Lock button. If you press that, does it toggle the rear panel on/off? Rear Lock has to be OFF to enable the system to use the rear controls.
 
  • Like
Reactions: MrRangerZr1

·
Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
I figured it out! I saw another post of somebody who had front air but no rear air or rear button turning on. I replaced my rear control unit and lo and behold it works in the rear now!
 

·
Registered
Joined
·
1 Posts
I figured it out! I saw another post of somebody who had front air but no rear air or rear button turning on. I replaced my rear control unit and lo and behold it works in the rear now!
What part number? What fuses should I check? 2007 Odyssey front air works great ac or heat. Rear on/off will not turn on just like described above.any help appreciated
 

·
Registered
Joined
·
116 Posts
I had this problem with my 2004 Ody. Maybe the solution is the same.

I had replaced the radio head unit, so I had the front control panel faceplate off, and to do that, I had to disconnect a bunch of wiring connectors. When I put it all back together, I forgot to reconnect one - apparently the one that lets the rear AC know what the front AC is doing. Up front, I didn't notice that the AC wasn't working in back, until days later when my sweaty kids started complaining. I had suspected that the unit in back was messed up, so after some banging on it, to no avail - it occurred to me to check the connectors under the front control panel. I attached the connector, and AC was restored. Kids happy - dad happy.
 
1 - 10 of 10 Posts
Top