Honda Odyssey Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Issues: Banging Noise when placing vehicle into reverse/ Hard banging sound when vehicle tranny downshifts going down hill.

I was told that the tranny is on it's way out & that is what the banging is.
I had a friend look at it & he discovered the rear engine/tranny mount & pass side motor mount torn. The "book" calls to drop the sub frame o remove to get it out. My friend got it out from the top of the motor with help from a co-worker.
He said that he always does them that way. He did it within an hour. Other shops said its a 4 hr job. Some said to remove the flex pipe, rack & pinon and the sub-frame. The side mount took 10 min to remove & replace.


Issue #2: The speedometer needle somehow went full circle and eneded up under the plunger near the ZERO mph. My friend took the dash apart and removed the cluster/plastic & spun the needle backward. My speedometer works & is accurate. The dealer wanted 1400.00 dollars to replace the cluster. They said they never heard of the needle "pegging" totally around. They also said the speedometer is broken & turning it back around won't work. They were wrong !!!

Just a FYI...... I was quoted 575.00 for the mounts & 1400.00 for the speedo cluster. I just spent 180.00 & the van tranny doesn't "bang" and the speedo works !

:):):):):
 

·
Registered
Joined
·
43 Posts
The "book" calls to drop the sub frame o remove to get it out. My friend got it out from the top of the motor with help from a co-worker.
He said that he always does them that way. He did it within an hour. Other shops said its a 4 hr job. Some said to remove the flex pipe, rack & pinon and the sub-frame. The side mount took 10 min to remove & replace.
That is really fast for the rear motor mount! Any additional details about how your friend accomplished this would be greatly appreciated. Thanks!

Regards,

Gregory Bender
 
1 - 3 of 3 Posts
Top