Honda Odyssey Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
I had the same problem, replaced the fuse. Actually, just pulled it out, and put it back in, and it started working. This worked for a little bit, and then it failed again. So I got a new one, (mini 7.5 I think), and replace it. Been working fine ever since.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Reseated Fuses, no luck, any other suggestions? I hear a "click" like power getting to the motors but no luck. Also, one side will open a small ways but nothing further. Any help would be much appreciated.
 

·
Registered
Joined
·
105 Posts
As a previous poster indicated, the failure of these rear vent window motors is well documented. A search on the forum will highlight the failures for you.

Luckily, mine failed within days of my extended warranty expiring, so I had them replaced free.

You'll have to choose whether to live with them being broken, replacing the motors yourself, or paying about $350 to have them replaced by the dealer.
 

·
Registered
Joined
·
6 Posts
New vent motors

My vents were slow and only opened part way. I found rear vent motors on RockAuto.com for $50 each. I just replaced the passenger side - tricky around the vent work - but not bad, less than an hour. My mechanic tells me the driver side is easy - no vent work. The new motor works well but is loud when the car is turned off. 2003 Odyssey. :tongue:
 

·
Registered
Joined
·
6,074 Posts
Relay location in diagram below...
 

Attachments

1 - 9 of 9 Posts
Top