Honda Odyssey Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
7,378 Posts
mappy, your case sounds exactly like the one rberman999 brought up...you missed all the bad stuff! I'll bet that belt stayed on (at least half of it did), and slipped enough (a couple-three teeth on the cam sprockets) to stop the motor without dinging anything.

If that's the case, it sounds like a keeper to me. I'd keep it and drive it until you get tired of it (or it gets tired of you).

Russ (if you're out there), you were right. Trying it your way first was the inexpensive and easier way to see if nothin' else major happened. Keepin' that in my bag of tricks.

As I said, I'm not an expert, Mickey Mantle.

OF
 

·
Registered
Joined
·
14 Posts
Discussion Starter #22
I put about 50 miles on over the weekend in varying conditions including highway and all still seems fine..I guess I plan to drive it for the week and if all remains ok, I'll turn it back over to the wife. :)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #23
Still looking good after 150 miles...I stopped by my mechanic last night and his advice was to not worry about it. So I guess I'll be keeping the van. Gotta love a post that starts with a frown face :( and ends with a smiley!:)
 

·
Registered
Joined
·
1 Posts
Mappy - it has been many years since this occurred. I currently have the same issue with my Accord. How did this play out? Did you end up having any engine issues with the Odyssey?

thank you!
 
21 - 24 of 24 Posts
Top