Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2005 EX with 70,000mi and just had the front engine mount replaced by a local mechanic. Before replacing the mount the engine seemed to be running fine.

Now when I start the van it starts rough and choppy and it also runs rough at idle when in gear. If I shift to neutral everything is normal, but when in gear at idle the engine runs rough. It's not a hiccup or miss, just rough, kinda like a dune buggy.

I've read in other posts that it could be the IAC or the EGR - it may be that these valves need to be replaced or cleaned. Where are they and how can you get to them easily?
 

·
Registered
Joined
·
9,323 Posts
It could be IAC but probably not EGR.

Before looking at that though, check out the front engine mount. You said the roughness started after that was replaced. Did they reconnect the vacuum line to the mount? Some aftermarket mounts have no vacuum fitting - if this is the case, the vacuum line should be plugged.
 

·
Registered
Joined
·
3,163 Posts
Why not go back to the mechanic. There could be any number of problems. Is check engine light on.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I'll look in there and see if there is a vacuum hose attached to the mount. There are no check engine lights on - I probably will take it back to my mechanic if I can't figure it out.

Before the mount was replaced I did notice a slight amount of extra engine noise/vibration when stopped but I attributed that to wear and tear and the van just getting older. But it became very clear once the mount was installed (at first I didn't make the connection). Is it possible that my rough idle problem is now more recognizable because of the new mount?
 

·
Registered
Joined
·
9,323 Posts
Since the old mount was shot, normal engine vibration would carry to the van's body and you would feel it. Absorbing that vibration is the mount's job. All other things being equal, you should feel less vibration, not more, after replacing the mount.
 
1 - 5 of 5 Posts
Top