Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
There is a noticable shake/judder when the ECO switches between the cylinders. noted at most speeds but most recognizable around 60 MPH. IS this the tranny judder that everyone is talking about? It seems to shift well but I am mildly concerned. It was purchased used and has almost 50K on the odometer. Is there an extended warranty period for the tranny. If so, would it apply to a used vehicle(2007) purchase. Thanks, scott
 

·
Registered
Joined
·
9 Posts
If the car is Certified Used, it will have a 12 months 12000 miles bumper to bumper and 7 years 100000 miles power tran warranty.
I also recently purchased a 07 EX-L and am feeling the same jitter while shifting down and switching to ECO mode.
Someone mentioned in a thread that it has to do something with Torque converter but its hard to prove to dealers as they always claim that its normal.
Is there anyone else around with same issue?
 

·
Registered
Joined
·
755 Posts
it could be your engine mount. go get it checked out at your

dealer ASAP since if your engine mount did fail, then riding

around with a broken engine mount can cause the other

engine mounts to fail, which costs freaking lots of money...
 

·
Registered
Joined
·
9 Posts
richysh said:
it could be your engine mount. go get it checked out at your

dealer ASAP since if your engine mount did fail, then riding

around with a broken engine mount can cause the other

engine mounts to fail, which costs freaking lots of money...
Is there a TSB for the engine mount issue?

I took my van to the dealer for this issue and they checked it (charged me $60) and told me that its normal.
Its better to have a TSB with you to get it fixed.
 
1 - 4 of 4 Posts
Top