Honda Odyssey Forum banner
81 - 89 of 89 Posts

·
Registered
Joined
·
9,994 Posts
compatible with DW-1 ATF
Well, his fluid is maybe compatible in some respects (e.g. viscosity?). But it clearly did not work in your Ody.

Lesson learned all around.

Thanks for the update. Do post a pic when you can.
 
  • Like
Reactions: 0dyfamily

·
Registered
Joined
·
173 Posts
I have been very careful with the van since the beginning (Muzzled, ATF change every oil change). Everything works great so far. Today I changed ATF and the van immediately started slipping after that. As I speed up, I can see the RPM moves up and down as if it is gear hunting but I think it's just compensating for the slippage. Sometimes, letting go of the brake will not move the van and I have to give it gas >1-1.5K RPM to actually move it.

The van is 2017, 67K km.

I used to do all my ATF change, this is the only time I did it at the garage. I guess that was the mistake??? I'm thinking of just order some ATF and do a 3 drain-fill cycles to see if it helps. Is this a good idea. It has been running perfectly before the ATF change so I don't think there is damage to it.

Thanks for your inputs.
Try disconnecting the battery for a few hours.
Try driving again.
 

·
Registered
Joined
·
1,986 Posts
It clearly says on the label that it is compatible with DW-1 ATF.
Sometimes it's all in the definition of terms. This could simply mean that you won't get a violent chemical reaction when you mix the two. Unlike sulfuric acid and water,
 
  • Like
Reactions: 0dyfamily

·
Registered
Joined
·
3,354 Posts
Try disconnecting the battery for a few hours.
Try driving again.
Instead of waiting a few hours, just touch the cables together for a second or two AFTER you disconnect the Neg from the battery, of course, Otherwise, a possible explosion and/or bad acid burn.
This will drain the capacitors and that is the same thing that is what is done by leaving it disconnected for a long time.
Leaving it disconnected is somewhat safer as long as you disconnect the Neg. :)
Buffalo4
 

·
Registered
Joined
·
173 Posts
Instead of waiting a few hours, just touch the cables together for a second or two AFTER you disconnect the Neg from the battery, of course, Otherwise, a possible explosion and/or bad acid burn.
This will drain the capacitors and that is the same thing that is what is done by leaving it disconnected for a long time.
Leaving it disconnected is somewhat safer as long as you disconnect the Neg. :)
Buffalo4
On our 15 odyssey the cables were not long enough to touch, so I just left em for a few hours.
 

·
Registered
Joined
·
1,986 Posts
No jumper cable, or 12 inch long piece of wire or copper pipe or aluminum or...any conductor?

Electrically connecting the two cables resolves issues that do not go away with just disconnecting.
 
  • Like
Reactions: 0dyfamily

·
Registered
2016 Touring Elite
Joined
·
2,122 Posts
No jumper cable, or 12 inch long piece of wire or copper pipe or aluminum or...any conductor?

Electrically connecting the two cables resolves issues that do not go away with just disconnecting.
Pressing the brake pedal does it with 0 risk...

-Charlie
 

·
Registered
Joined
·
173 Posts
0dyfamily. So I bought a 2015 minivan with maybe one ATF change at around 80k miles. Now the van has 197k miles. The transmission is fine, maybe a little shaky around 30mph but nothing major. Do you recommend a change the ATF even if the color is brown?!?!!?
Yes ----do 3 drain and fills, go for a 5 min drive between each drain and fill.
I just did this to our 15 ex.......made a huge difference in shifting and acceleration.
I used maxlife atf, red jug.
3.5 quarts for each drain.
Refill through the dip stick tube. Easy peasy.....quicker and easier than an oil change.
 

·
Registered
Joined
·
69 Posts
Update. I went to see the mechanic today and he showed me the oil drum he used for the ATF. It clearly says on the label that it is compatible with DW-1 ATF.

I tried to take a picture but my kid played with the phone and changed it to 5sec timer.... let's just say that the resulting picture is rather uninteresting. I'll do it again next time.

He now stocks Honda DW-1, to be used at least for the Ody.

yeah let us know what it was... quite curious... I am running Maxlife Val 3x drain/fill now, then I had added Lubegard platinum (already had it), and not it is butter...

I will be installing a trans cooler and changing the external trans filter on my 6speed TE. I will also add a magfilter too
 
81 - 89 of 89 Posts
Top