Honda Odyssey Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Dear Honda Gearheads:
I will be taking my EX-L into the dealer for the second time for constant speaker electrical pops that cut out the audio (from any source). Popping occurs even when van is in Accessory Mode and when ventilation fan is off.

The first time, they replaced the tuner. This worked for about 3 months. Now the crackles are back, constant, and louder - they start about 7 minutes into my drive.

I searched the forum archives for this problem, but it wasn't until I searched the Pilot forum that I found possible answers and solutions.

The cause, according to one contributor, is "an under-engineered Compressor Clutch Solenoid". The relay takes on the shock from the AC Compressor and when the relay wears out, the electrical shock is absorbed by other circuits (the radio). Therefore, replacing just the relay won't work.

Two Solutions that I can find:
1. A dealer-repair. The repair must include replacing the AC Compressor, Clutch Relay, Compressor Coil, and Compressor Clutch. If all four are not replaced, the popping will return.
https://www.piloteers.org/forums/114-2016-third-generation-pilot/107474-random-electrical-snapping-cracking-sound-elite-2.html (post #28)

2. A drive-way jerry-rig repair: soldering two wires onto a diode. Diode wire inserted into relay bay with the relay and the other end grounded to the body.
https://www.piloteers.org/forums/114-2016-third-generation-pilot/155577-diy-get-rid-ac-clutch-popping-sound.html

I want to go into the dealer this Saturday armed with information, so I have a few questions:

1. Does the AC Compressor and related parts run even when not running air conditioning into the cabin? It's winter here; I'm not blowing cold air into the car, but popping problem has occurred. Popping even occurs when the fan is off. Popping also occurs in Accessory Mode/engine off.

2. The above solutions were on 2016 and 2017 Pilots (the forum said this problem occurs on TSX, Odyssey, Ridgeline, and TL). Even though the 2018 Odyssey is a new generation, is it possible some of the same parts have not changed in design for the 2018?

Thank you for your advice, suggestions, and knowledge.
c
 

·
Registered
Joined
·
360 Posts
Dear Honda Gearheads:
I will be taking my EX-L into the dealer for the second time for constant speaker electrical pops that cut out the audio (from any source). Popping occurs even when van is in Accessory Mode and when ventilation fan is off.

The first time, they replaced the tuner. This worked for about 3 months. Now the crackles are back, constant, and louder - they start about 7 minutes into my drive.

I searched the forum archives for this problem, but it wasn't until I searched the Pilot forum that I found possible answers and solutions.

The cause, according to one contributor, is "an under-engineered Compressor Clutch Solenoid". The relay takes on the shock from the AC Compressor and when the relay wears out, the electrical shock is absorbed by other circuits (the radio). Therefore, replacing just the relay won't work.

Two Solutions that I can find:
1. A dealer-repair. The repair must include replacing the AC Compressor, Clutch Relay, Compressor Coil, and Compressor Clutch. If all four are not replaced, the popping will return.
https://www.piloteers.org/forums/114-2016-third-generation-pilot/107474-random-electrical-snapping-cracking-sound-elite-2.html (post #28)

2. A drive-way jerry-rig repair: soldering two wires onto a diode. Diode wire inserted into relay bay with the relay and the other end grounded to the body.
https://www.piloteers.org/forums/114-2016-third-generation-pilot/155577-diy-get-rid-ac-clutch-popping-sound.html

I want to go into the dealer this Saturday armed with information, so I have a few questions:

1. Does the AC Compressor and related parts run even when not running air conditioning into the cabin? It's winter here; I'm not blowing cold air into the car, but popping problem has occurred. Popping even occurs when the fan is off. Popping also occurs in Accessory Mode/engine off.

2. The above solutions were on 2016 and 2017 Pilots (the forum said this problem occurs on TSX, Odyssey, Ridgeline, and TL). Even though the 2018 Odyssey is a new generation, is it possible some of the same parts have not changed in design for the 2018?

Thank you for your advice, suggestions, and knowledge.
c


The AC compressor will run when the system is in window defrost mode, but if it’s happening when you’re fan is off, well, the compressor should t be running if the fan is off.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Got the diagnosis: bad wire harness. It takes a week to repair because it’s such an odd part needing replacing. It’s having to come from out of state. Hopefully this is the proper fix this time.
 

·
Super Moderator
Joined
·
1,163 Posts

·
Registered
Joined
·
2 Posts
Got the diagnosis: bad wire harness. It takes a week to repair because it’s such an odd part needing replacing. It’s having to come from out of state. Hopefully this is the proper fix this time.
Got an Odyssey any month ago and got the same problem. It was used with 12000 miles on it. How’s your Honda doing with the repair?
 

·
Registered
Joined
·
1 Posts
I am also having this problem on my 2019 EX-L and was told there is an intergalactic backorder on harnesses. Clearly something is defective.
 

·
Registered
Joined
·
17 Posts
Got some errors in the diag screen - Meter:CRITICAL_UNLOCK and Meter:SUDDEN_SIGNAL_OFF. Looks like a winner here... do I tell the dealer I found these, or do I just say "got some crackles, figure it out"?
 

·
Registered
Joined
·
360 Posts
I am also having this problem on my 2019 EX-L and was told there is an intergalactic backorder on harnesses. Clearly something is defective.
Right.. I find they drag their feet on warranty repair. The way I figure it, if they make it take 6 months for the part to come in then they only need to replace it twice a year.

The way I understand it, they used a connection that is too delicate. It’s too easy for their service techs to damage them then working in that area. Hopefully vibration doesn’t have any affect to them in the long run.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
17 Posts
Appointment made for Friday, service writer seemed to know precisely what issue is, so we'll see... more to come.

2019 EX-L Navi/Res, by the way. 1000 miles on the clock.
 

·
Registered
Joined
·
17 Posts
Well, kids - not good news here. Took to dealer, since they can’t get it to recreate they’re doing nothing. The logs in the head unit apparently mean nothing to them. Best part was when I asked about them and service writer said there weren’t any. Showed a pic of the errors.

needless to say I’m not pleased. Told them I’m bringing it back in a week, I want a loaner, and I don’t want it back until it’s repaired.

more to come.
 

·
Registered
Joined
·
17 Posts
And now a new feature found this evening - rear entertainment video display not working - at least not for playing the video. Audio plays just fine. Weird. Check out this video I made:

 

·
Registered
Joined
·
17 Posts
And now my wife called me using Apple CarPlay - the head unit didn't register it, I could hear her, and her voice went between regular voice and crazy garbly mouse voice. This thing is possessed.
 

·
Registered
Joined
·
17 Posts
Well, not great news. They can't get it to recreate (of course...would you expect anything else? that's what vehicles do when they go to the shop). Was told that Honda is aware of the issue, has no fix, mentioned a harness... not really sure where to take the issue at this point. The RES wasn't a free add-on... any ideas on course of action with Honda corporate would be delightful. Is there someone I can send an e-mail to or make a call that might help them prioritize the issue?
 

·
Registered
Joined
·
6 Posts
We have a 2019 Odyssey EX. Have the following issues almost everyday:

  • Static from speakers
  • Radio unavailable
  • Network communication lost
  • Blank Screen
Also has issues with the backup camera not working and no sound from the radio even though the radio is on.

Our dealer has only done a reboot of Infortainment system. The 2nd time I took it in I was told they were advised not to look at vehicles with Infotainment issues since there is no fix.

I am currently in contact with a lemon law attorney.
 

·
Registered
Joined
·
5 Posts
Saw a link in a Youtube video about the noise in a Pilot and someone linked to a Service News Article which says the noise is caused by the MOST bus network connections.
Yesterday there was an update to a TSB regarding the MOST bus Network failure log.
 
1 - 20 of 39 Posts
Top