Honda Odyssey Forum banner

21 - 40 of 51 Posts

·
Registered
Joined
·
6 Posts
Good grief, that's terrible. Mine is nowhere near as bad... I hope there's a fix for you soon.
That's the problem-I was told by our dealer there is no fix.

I drove the car multiple times yesterday and had all of these issues again.

I just want to know if anyone actually has had this fixed because we are frustrated buying a car we thought was the best minivan on the market.
 

·
Registered
Joined
·
1 Posts
That's the problem-I was told by our dealer there is no fix.

I drove the car multiple times yesterday and had all of these issues again.

I just want to know if anyone actually has had this fixed because we are frustrated buying a car we thought was the best minivan on the market.
My 2020 just did the crackling sound, back out camera isn’t working, and dash screen went black.
 

·
Registered
Joined
·
17 Posts
I did take a look at historical temperatures the day the vehicle really acted up... all over about 40 degrees. On really cold days it doesn't seem to have the issue. Any correlations that can be drawn on temperatures? And no... no fix yet.
 

·
Registered
Joined
·
11 Posts
I've been getting the static-y popping noise just after 1,000 miles on my 2020 EX-L. I don't have NAV-RES. There are no fault codes showing either. When I turn fader all the way to the back, I still can hear popping from the front speakers. There is noise when sound is off. When I turn up music to try to drown it out, the popping noise get louder.
I've taken it in twice already. First time they claimed they can't hear it. Second I requested a ride with the service tech, who could hear it. Now I have to reschedule so they can spend a few days trying to diagnose it.
The noise goes away with engine auto-stop, and is more frequent when accelerating.
Has anyone had experience with Lemon Laws? Do they cover annoying sounds?
Also, does it matter which dealership I take it to? Will I have more luck at the one I bought it from?
 

·
Registered
Joined
·
1 Posts
Hi All,

I have a 2020 Pilot EX-L with similar symptoms that started within days of the purchase. Loud static / popping sounds from speakers, then rear entertainment system froze, and then the infotainment system started shutting off with "network communication lost" error message on the screen. Both the main screen and the driver's screen with speedometer shut off.

Dealer checked all infotainment system connections during the first maintenance visit. Problems persisted. After second visit the dealer (with consultation from Honda's main US office) rechecked wiring connections and ordered a replacement wiring harness. It'll take a week to receive and then 1-2 days to install.

Will give an update after harness is replaced. Seems like many Honda vehicles are having similar issues.
 

·
Registered
Joined
·
1 Posts
I have a 2018 Odyssey EX and I have all the symptoms mentioned in this forum about cracking sound from the speakers. I also loose blutooth connection because of the cracking sound. The van is in the shop now for replacement of the dash and floor harness. I hope this fixes the problem.
 

·
Registered
Joined
·
3 Posts
Has anyone attempted to use their state's lemon law to return/refund their vehicle due to this persistent problem?
 

·
Registered
Joined
·
35 Posts
I’m having the same sound/issue but it’s isn’t all the time. The dealer is replacing my amp next week. We will see if that helps. My navigation won’t load either so I think a new head unit is in my future as well. :(. They are going to tackle that after the amp. Weird issues but I’m glad they are happening while under warranty. I’m still happy with the car.
 

·
Registered
Joined
·
1 Posts
Purchased a 2020 Honda Odyssey in November and started noticing annoying electrical pops from the speaker a few weeks ago. They seem to happen when engine is engaged; when not running they happen seldom. Happens with radio on or off and adjusting the fade doesn’t move where the pops come from (mainly up front dash left/right). Unsure if they pop in the back as well. Can’t ignore it now it’s super annoying. Seems like this is an issue Honda should be aware about and able to fix. Not happy this is happening only 2months in and around 2500 miles. First world problems yo.
 

·
Registered
Joined
·
17 Posts
Looks like a new harness is in my future. Part should be in this week, expect the repair will occur next week sometime. Stay tuned... service person said that the replacement harness is "the fix." We'll see.
 

·
Registered
Joined
·
11 Posts
After 3 trips to the dealership, my problem was only a loose blue connector in the back. Now I don't have the popping sound anymore. Wished they would have pushed that plug in on my first attempt bringing it in. Was definitely frustrating for a brand new ~$40k vehicle to not have the radio plugged in properly and the dealership try to deny there's a problem.
 

·
Registered
Joined
·
17 Posts
Looks like a new harness is in my future. Part should be in this week, expect the repair will occur next week sometime. Stay tuned... service person said that the replacement harness is "the fix." We'll see.
Harness replaced. Same results as before. Dealer holding on to van and asking Honda what to do next. Got an elite to drive in the meantime - that heated wheel is sweet!
 

·
Registered
Joined
·
17 Posts
Harness replaced. Same results as before. Dealer holding on to van and asking Honda what to do next. Got an elite to drive in the meantime - that heated wheel is sweet!
Van is back. Not sure where the miscommunication was with it happening again and not again... but it's done and back at home. Here's the summary:

Customer states center display will show loading, with movie playing audio will crackle and no display in rear. This is an ongoing concern.
Please check for any hard failures set.
Suspect dash harness ordered. Customer states that the infotainment system is unusable.
Was able to hear light crackling. During removal of dash harness found one of the MOST connections to bluray player were pushed off to the side due to honda's original wire routing. may be the problem but unsure. replaced dash harness. crackling noise now gone. suspect problem is fixed.
Played movie for 30+ minutes with no concern while in park and being driven. Honda did announce today they are investigating this concern and working on the concern.

Harness PN 32117-THR-A35
 

·
Registered
Joined
·
3 Posts
My dealer replaced the Gauge Control Module. The infotainment system shut down less than a minute after I drove the van away from the shop. I turned back around and told them I'd be bringing it back in later in the week.
 

·
Registered
Joined
·
884 Posts
Mine is going in for this issue tomorrow. Dealer tells me they have replaced wiring harnesses for three other owners.
 

·
Registered
Joined
·
1 Posts
We bought our 2020 EX-L Honda Odyssey at the very end of November and noticed the popping mid Dec. first appointment to the shop was just after Christmas. They did nothing at first until I sent them video evidence and returned 3 additional times. Sent home on Jan 14 after reattaching a loose wire. But popping and audio issues persisted. Received harness diagnosis on the 21st. Was told the part was on back order until April 15. Will state lemon laws cover this issue? American Honda said this issue was not eligible for the warranty buyback program.
 

·
Registered
Joined
·
374 Posts
Van is back. Not sure where the miscommunication was with it happening again and not again... but it's done and back at home. Here's the summary:

Customer states center display will show loading, with movie playing audio will crackle and no display in rear. This is an ongoing concern.
Please check for any hard failures set.
Suspect dash harness ordered. Customer states that the infotainment system is unusable.
Was able to hear light crackling. During removal of dash harness found one of the MOST connections to bluray player were pushed off to the side due to honda's original wire routing. may be the problem but unsure. replaced dash harness. crackling noise now gone. suspect problem is fixed.
Played movie for 30+ minutes with no concern while in park and being driven. Honda did announce today they are investigating this concern and working on the concern.

Harness PN 32117-THR-A35
There is a service bulletin about the MOST connector and the related static sounds.


Sent from my iPhone using Tapatalk
 
21 - 40 of 51 Posts
Top