Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Here's the story, it's long but probably necessary.

The passenger side seat belt was stuck, and we took our van it to get it replaced. But the problem was actually the aftermarket speaker. It turns out the magnet was close enough to cause the seat belt to lock.

I removed the speaker, and installed some nylon spacers and replaced the speaker. As I was testing to make sure the passenger side rear speaker was working, I noticed the driver side speaker had no sound.

So, I removed the driver side speaker cover, one of the speaker wires was not connected. I reconnected it and I could get sound from the speaker.

Now here's the strange part. As I was screwing driver side speaker in, the sound just stopped. I checked all speakers using balance/fade, and ALL speakers don't have sound.

The head unit still has power. I can change the source input, radio channels, play a CD, but no sound?

any ideas? I'm stumped.
 

·
Registered
Joined
·
31 Posts
I know this is an old thread but hopefully this will help. I was having the same problem with my 2007 Odyssey Touring and searched all over this and other forums and found many other Honda owners having the exact same frustrating issue. Nothing worked. I replaced the fuses # 5 and #32 on the drivers side. No good. I installed a new radio. Did not fix it. Could not find any fuse labeled "Amp" or "Speakers" or similar anywhere. Finally I posted my own thread and an awesome person with the handle of "PostalTech" said to check fuse #5 in the small underhood fuse box. It was a 20 AMP fuse labeled "Premium" and it was blown. Also a 7.5 amp fuse for rear entertain was blown. Replaced both and sound restored. Your fuse boxes or labels may not be exactly the same as mine but I learned the lesson before I start chasing down more complicated problems to pull and check all fuses before moving on to more exotic solutions. Hope this helps others!
 

·
Registered
Joined
·
1 Posts
My wifes 07 touring stereo makes no sound. I replaced the 2 fuses that you mentioned JSMCO but nothing. Radio comes on but no sound. I checked literally every 7.5, 10, 15, and 20amp fuse and 2 were blown, the 20a and the 7.5 in the secondary underhood fuse box. Pulling my hair out. I would love to know how to fix this.
 

·
Registered
Joined
·
244 Posts
Here's the story, it's long but probably necessary.

The passenger side seat belt was stuck, and we took our van it to get it replaced. But the problem was actually the aftermarket speaker. It turns out the magnet was close enough to cause the seat belt to lock.

I removed the speaker, and installed some nylon spacers and replaced the speaker. As I was testing to make sure the passenger side rear speaker was working, I noticed the driver side speaker had no sound.

So, I removed the driver side speaker cover, one of the speaker wires was not connected. I reconnected it and I could get sound from the speaker.

Now here's the strange part. As I was screwing driver side speaker in, the sound just stopped. I checked all speakers using balance/fade, and ALL speakers don't have sound.

The head unit still has power. I can change the source input, radio channels, play a CD, but no sound?

any ideas? I'm stumped.

Is it possible you touched the speaker wire on the other terminal for a second?

If so you may have shorted the amplifier, this being the case you are going to have to get someone familiar with car stereos to advise.

Hopefully it is a simple fix, if possible try and pull up the circuit diagram of that piece of equipment or drop a line to the manufacturer, there might be some protection device just prior or with some detective work it might be reparable.
 

·
Registered
Joined
·
1 Posts
My wifes 07 touring stereo makes no sound. I replaced the 2 fuses that you mentioned JSMCO but nothing. Radio comes on but no sound. I checked literally every 7.5, 10, 15, and 20amp fuse and 2 were blown, the 20a and the 7.5 in the secondary underhood fuse box. Pulling my hair out. I would love to know how to fix this.
I have the same problem it’s driving me crazy how do you ever find out how to fix that problem
 
1 - 7 of 7 Posts
Top