Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
anybody have any idea? after cleaning my engine compartment the check engine light and TCS came on, and whenever i press on the throttle at 3,000 rpm the engine shuts off!

i only lightly hose down the intake manifold i was even carefull at cleaning the area near the oxygen sensor
 

·
Registered
Joined
·
6,074 Posts
Get the code checked and report back.

You may have a bad coil(s) or sensor.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #3
everythings ok now! just cleaned up some of the electrical connectors on the intake manifold with wd40 and disconnected the battery for 10 min! all is good! never came back on! thanks for the quick reply
 

·
Registered
Joined
·
1 Posts
I had the very same thing happened to my 04 Odyssey after I washed the engine. I WAS FREAK'N OUT. I did like he said (unhooked the battery cables from the battery for half an hour or so). Hook battery back, start her up and the check engine light did not stay on. I've been driving it for two days now and everything is normal.
All I can figure out is that unhooking the battery resets the computer memory that tracks the codes for something that went wrong (like a sensor getting wet). Even when that sensor dries up, the computer still remembers the initial detection and had to be reset (like unhooking the battery).
Thanks for sharing and hope others benefit from this as I did.
 

·
Registered
Joined
·
3,163 Posts
When the problem is corrected the Check Engine light will stay on for several drive cycles before it is reset. Reading the code would have given you an indication of which senser water is getting in and it could have been corrected. As it is you are subject to get the failure in a driving rain storm or possible high humidity. It is also subject to corrosion over time.
 
1 - 5 of 5 Posts
Top