Honda Odyssey Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Well I had a check engine light on my 04 van. It has 115K on it. We
had Honda put in a rebuild at 80k under warranty three years ago. There are
no symptoms I can feel right now. The shifts are smooth and maybe on the
soft side, but it does not feel like its slipping. I had the fluid changed at
105. We also have had a heavy duty oil cooler installed when the car was
new. We have towed with it, but much less in the last few years. Just invested a grand into it , including new timing belts...seems to run fine and
we want to keep this car at least until 200k.

I have read lots of tranny threads but still am confused on what to do.
I know I can extend the life with a fluid change now...maybe cleaning solenoids? I am a good wrencher, we race corvettes and have replaced every
major component on these cars over the years. Need some good advice!
 

·
Registered
Joined
·
6,074 Posts
P0720 - then troubleshoot the Countershaft Speed Sensor circuit for a short, loose connection, poor ground or bad sensor.
 

·
Registered
Joined
·
6,074 Posts
At least it is not the dreaded P0740 code.

The code you have appears to be caused by an electrical circuit problem and not a mechanical problem in the transmission.
 

·
Registered
Joined
·
6,074 Posts
Did you just have some work done recently prior to this P0720 code occurring? It may be an intermitment thing too from what I have read on this code. I would still troubleshoot the circuit and sensor before I cleared the code and see if it returns.
 

·
Registered
Joined
·
6,074 Posts
P0720 Troubleshooting and location of Output Shaft (Countershaft) Speed Sensor...
 

Attachments

1 - 8 of 8 Posts
Top