Honda Odyssey Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a problem with my 2009 Honda Odyssey EXL. The radiator fan will not turn on and I have incredible fuel consumption. I already checked both ECT are ok, I checked all relays and fuses are ok. I checked the ECT connectors and they are fine both has voltage and continuity. The fans are fine because I made a direct connection with a clip on both the fan relays; it's the only way they turn on. I used a scanner in the auto zone and it shows these codes P2185 (Engine Coolant Temperature Sensor 2 Circuit High), P0118 (Engine Coolant Temperature Circuit High), and P0117 (Engine Coolant Temperature Circuit Low). I don't understand why show that, if both ECTs are fine. I don't know what else to check. Any suggestions will be appreciated, thank you.
 

·
Registered
Joined
·
10,518 Posts
Those sensors are not expensive, so I would outright replace them (with OEM only). Driving with those codes is not only costing you fuel, it could also ruin your catalytic converter.

If instead you want to investigate further,
  • Identify which sensor is at fault.
  • Identify the PCM connector pin for the sensor.
  • Retest the sensor from this pin, rather than from the sensor terminal.
Sorry for the lack of details. Those missing details would be found in a wiring diagram for your 2009, which I don't have.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I see. I already replaced both sensor but not with OEM..., It's crazy because I tested them with a multimeter, they look are working correctly applying different temperature. But OEM it's always better. I'll get them OEM and try again.
Really thanks.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top