Honda Odyssey Forum banner

Transmission problems after engine swap

5226 Views 7 Replies 5 Participants Last post by  OdyVanMan04
This is my first post on this forum. I have been working on Hondas for many years and this is my first honda odyssey. I bought it with a bad motor, had a rod go through the block.

Long story short i replaced the motor. First test drive everything seemed fine. But now I'm having trouble with the transmission. It was a rebuild from AAMCO and apparently only has about 12k miles on it.

The problem is shifting into the gears. I can no longer go below D4 and when i shift into Reverse it just revs the motor like its in neutral. I can't get into D3, 2, 1. Reverse was working when we first were testing eveything, then we lost it and cant go below D4. I can drive it around in D4. Also when in park, the speedometer revs with the tacometer. So if i rev the motor the speedometer goes up just like the tacometer.

This is my first automatic Honda transmission. Any help would be appreciated.
1 - 8 of 8 Posts

· Registered
Joined
·
1,051 Posts
This is my first post on this forum. I have been working on Hondas for many years and this is my first honda odyssey. I bought it with a bad motor, had a rod go through the block.

Long story short i replaced the motor. First test drive everything seemed fine. But now I'm having trouble with the transmission. It was a rebuild from AAMCO and apparently only has about 12k miles on it.

The problem is shifting into the gears. I can no longer go below D4 and when i shift into Reverse it just revs the motor like its in neutral. I can't get into D3, 2, 1. Reverse was working when we first were testing eveything, then we lost it and cant go below D4. I can drive it around in D4. Also when in park, the speedometer revs with the tacometer. So if i rev the motor the speedometer goes up just like the tacometer.

This is my first automatic Honda transmission. Any help would be appreciated.

What year is your Honda? Search this website. Transmissions are a known problem with Honda.

AMCO should be 3yr/36K warrenty. Don't wait. Get it fixed. Find a good
AMCO shop. Quality varies among shops. Find one that has a good reputation. Do not go back to the shop that did the orginal replacement.

AMCO shops usually take out the transmission and install the transmisssion.
The actual rebuild is subed out. Find out who does the actual work.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
It's a 2000 EX. The van was sitting for 2 years before i got it because of the motor problem. I think its an electrical issue because of the speedo jumping around when its reving in park. And it did work fine for the few times up and down the driveway. The fluid was super clean when i drained it to pull it out to replace the engine. Would a bad sensor cause the issues? I have no check engine light. Just cant get it below D4 anymore and no reverse.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
So i figured out how to get into D3, 2, 1. I did not realize that after you are in D4 you can not have the handle pulled in towards you. All that is needed is to just push the handle down into D3, then once there you can pull the handle in and get to 2, 1.

So now the issue is no reverse. And the speedometer acts like a tachometer.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
I got reverse to work again. I did not mention that im still having an issue with a high idle. The Idle was hanging around 2000 rpm so when i went to Reverse it wouldnt engage because of that. I got the idle down enough for reverse to engage.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top