Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
this car has been great to my family as my first car as I purchased new and paid cash at age 20 when we had our first son. the car is now paid off but I am having two problems.

1 problem. when accelerating around 1900 rpm, I here a chaffing/ something rubbing together sound.
2nd problem. I have been smelling something burning all day today, well since I cut my heat on for the first time in a while this morning. it does not smell like coolant and I checked all my fluid levels and everything seems level or slightly below level for 70k miles. after smelling all of the fluids, it smelled closest to the brake fluid. I have no idea on how to work on newer motors/honda motors, but I'm pretty good on old chevy motors, if anyone has Amy suggestions before I take my car to a mechanic tommorow let me know.

also are tsb's covered by Honda if your car is out of warranty? I'm debating taking my car to the dealership
 

·
Registered
Joined
·
613 Posts
first of all congrats on being so fiscally responsible at such a young age! As a financial adviser I rarely see folks like you.

You may have a bad motor mount or loose heat sheild. Do you have LX or EX? The VCM engines have history of breaking motor mounts, and they are not too bad to replace if you have time and skill and tools, but $$$ to buy.

Sometimes heat does smell funny, check your vent system for mice? If you have a coolant leak a pressure test will do it, also will leak either to outside or in vehicle.

good luck.;)
 

·
Registered
Joined
·
3,163 Posts
If the heat hasn't been on for a long time it could just be the dust that collected over time. You should check the cabin filter if it hasn't been changed. Funny how the smell of smoke hangs around forever.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #4
I think something burned onto my exhaust, I'm going to find out for sure later when I lift the car
 

·
Registered
Joined
·
56 Posts
Discussion Starter #6 (Edited)
Just a FYI, problem fixed

If you hear a shhhhh sound while driving, it was the bottom of the exhaust heat shield corroding and breaking away from the nut and bolt, I had a temp fix of prying the heat shield away from the manifold and the total fix including new shields and labor is 262 for me including tax
 
1 - 7 of 7 Posts
Top