Honda Odyssey Forum banner
1 - 20 of 54 Posts

·
Registered
2005 EXL donated 243K ,2019sienna XLE AWD
Joined
·
1,125 Posts
Hey guys and gals with 2005-06 Ody, after spending significant amount of time, I was finally able to locate the proper plugs for 05-06 Ody ECT sensor. I bought 10 of each, and 100 ohm resistors.
I will make 10 plug and play harnesses, one for myself and will offer 9 to fellow Ody forum members on first come first serve basis. I expect the parts to arrive within next 2 weeks.
PM me for further details.
thanks
Max
PM'ed Thanks
 

·
Registered
2005 EXL donated 243K ,2019sienna XLE AWD
Joined
·
1,125 Posts
lol, DD, trust me the install will be alot simpler than that. You will have a present in your mailbox today!
Correct! Thanks Max for the MOD! PROFESSIONAL PACKAGING! I can feel a better throttle response. Maybe it's me but I have better pick up and no vibs. Now I can enjoy my van like the EX and LXmodels! Installation was about 5 mins. 2005 exl
 

·
Registered
2005 EXL donated 243K ,2019sienna XLE AWD
Joined
·
1,125 Posts
Still smooth ramping to 65mph very little vibrations around 65 .Probably need new engine mounts anyway.
This mod really turned my honda/suzuki 3cylinder back to a real vtec v6.
 

·
Registered
2005 EXL donated 243K ,2019sienna XLE AWD
Joined
·
1,125 Posts
I have been following the obd i/m readiness status on my ody for the last 6 months and the catalyst sensor was/is always not ready no matter how many miles I drove. No codes either.Thankfully I can still pass state inspection with one not ready code. Would oil ala VCM have fouled the catalytic converter? Or is there a sensor that needs replacing? Hope it 's not the catalytic converter thst needs replacement!
 

·
Registered
2005 EXL donated 243K ,2019sienna XLE AWD
Joined
·
1,125 Posts
I used to use Torque after having spent the time to set it up the way I wanted. However, I ended up switching to Dash. It's much easier to use and is free with a fairly nice interface.
Full app is about $10.Has anyone done a dynomometer testing on a vcm modded odyssey?Love to see the low end torque values.
 

·
Registered
2005 EXL donated 243K ,2019sienna XLE AWD
Joined
·
1,125 Posts
Check the connector for the resistors, make sure is clicked in. Check for continuity from one end of Muzzler to the other. Also disconnect the blue connector and see what happens when you start the engine. If you get the VSA error, then there is a open circuit on the Muzzler.Possibly not inserting the resistor fully.
 
1 - 20 of 54 Posts
Top