Honda Odyssey Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I noticed some orange spots in my driveway and decided to check under that van to see where it was coming from. Looks like its coming from the front engine mount. The mount looks intact from every angle that I can view it from but can't see where it connects to the engine. Anyone seen this before from a blown front mount? Or should I be looking elsewhere?

2008 Touring VCM Tuner
 

Attachments

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
First thing I would check is coolant reservoir to confirm coolant is clear and not mixed with engine oil which will make this sort of color (on some brands). It would indicate head gasket leak.

Otherwise, I have no clue unfortunately.

EDIT: Open the coolant cap (when engine is cold) and confirm. Not just reservoir.
The coolant is still blue and the oil is still brown. Good point. Thanks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
So all fluids levels are normal..

Seems the van got it from road. Can you clean it thoroughly and check again after few days?

The A/C evaporator drain tube, is not blocked right?
Fluid levels all normal. Just replaced the power steering and trans fluid last weekend. Oil changed about a month ago. Coolant level in the reservoir at max line.

In the front of the engine so couldn't be the AC drain tube but checked it and its OK.

Looking at the mount again I noticed a deflated spot near the front. Maybe it is the mount.
 
1 - 5 of 5 Posts
Top