Honda Odyssey Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Could it just be coming from the o-rings? Maybe I didn’t tighten it enough? Is every where that shows green a leak?
IMG_4493.jpg

IMG_4495.jpg

IMG_4494.jpg
 

·
Registered
Joined
·
384 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
Never heard of such a thing but I ll give it a try. Do I put some around the o-rings? I just used blue thread locker on the bolts when I put it back together.
Thanks for your input.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #5 ·
So….is weeping ok because I just got done weeping, trying to figure out why I keep running out of Freon
 

·
Registered
2012 EXL. 2013 Touring
Joined
·
309 Posts
So….is weeping ok because I just got done weeping, trying to figure out why I keep running out of Freon
The tricky places are the evaporator under the rear side panel. The pipes under the car that go into the rear air…corrosion. Also the Schrader valves in the service connectors.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #7 ·
Interesting, I just figured the leak would be coming from here since I just installed the compressor and accidentally cut the HP line attachment when I had to use me dremmel to cut it out. I’ll look around for this places though….
 

·
Registered
Joined
·
2,271 Posts
OP, I didn't know you were addressing AC!

I actually just took my BMW to a friend's shop, as the AC was crappy in the 'big' heat. Turns out it was only 100 grams low, but enough, because the total capacity is small, around 600 grams, to make the AC useless.

So yes, weeping is a problem on AC systems!
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #9 ·
Interesting…thanks for your reply.

So I took the adapter off and it looks like this probably is the culprit. Looks like it might be leaking from the HP line and maybe the JB Weld I used to fix this cut is not letting it sit properly. I’ll try sanding it down a bit…
IMG_4496.jpg
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #12 ·
I just replaced that o-ring with a thicker one. I think the ones I replaced on the hoses themselves are good.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #13 ·
Well, it’s appears to be purging out Freon from the bottom now. I guess I ruined something? I replaced all relays and the compressor WANTS to come on but when it starts, it starts purging. Guy I know said I probably clogged something with the leak sealant cans I pushed through. Is it possible that I ruined the new compressor?
 

·
Registered
2006 Honda Odyssey (EX)
Joined
·
2,130 Posts
Guy I know said I probably clogged something with the leak sealant cans I pushed through.
This is most definitely possible and why we never recommend using those leak sealer cans.
 

·
Registered
Joined
·
2,363 Posts
those pictures are pretty telling...

a bag of O rings for the entire system will run you 10 bux.

I just went through this 4 hour hell today on my acura ilx.
compressor, condenser, seals.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #16 ·
So I’m guessing I need to start replacing parts? Do I do it randomly? Start with the condenser ? Or throw the van in the trash?
 

·
Registered
Joined
·
5,897 Posts
This is most definitely possible and why we never recommend using those leak sealer cans.
Those things cause a lot of damage. Now OP probably has to watch my videos on replacing all the A/C components lol
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #20 · (Edited)
Link ?
I don’t understand how a relay got some of these folks up and running again.
Is the compressor the best place to start or should I get a professional opinion first.
 
1 - 20 of 22 Posts
Top